Page 1 of 1

AMB Version 5 NOT Exporting to ODT

Posted: Sat Mar 14, 2020 2:51 pm
by skc
One of the reasons I upgraded to Version 5 was the ability to export to Open Office, .ODT
However this does not seem to work. All I get is an odt file which will not open.
I approached Support about a month back. They did come back to me asking for the faulty file which I sent them.
Now despite my repeated queries, I am getting no feedback at all from return emails as well as queries on their Facebook page. (They seem to remove the posts?)
This poor feedback makes me quite wary of future upgrades an AMB as well as AMM, which I also have.
If anyone has similar issues and can provide some useful feedback I will appreciate.

Posted: Mon Mar 16, 2020 3:24 pm
by Viki
This has me intrigued. Open Office should be compatible with MS Word (and visa versa).
Note: I do not have Open Office - maybe someone else will chime in with their recommendations...
Would you provide more details about which templates you have tried?

When I tried exporting my catalog to ODT (using a text based template), MS Word refused to open the document citing an "Illegal Name Character" as the culprit for the error.

But, if I choose to use an ODT template that exports the books' covers it is successful!

Digging around for the list of illegal characters in Word brought me to this information -
Some of the forbidden Characters are:
Numbers before names, Superscript/Subscripts, " ' \ | / < > { } [ ] << >>

Numbers after Names are okay. None of these characters can be used in name of Hard Drive, Directory Names, and any File Names.

And on servers no names can have the name File or Fileserver in any path names.

You can use _ (underscores).

Added after 1 hour 16 minutes:
Found the solution that worked for me....

(ALWAYS a good idea to backup your database prior to attempting changes on a global scale)

Close AllMyBooks
Find your db on your computer, right-click, and "Open With.." and choose "Access.exe"
On the left side (under "All Tables"), choose "books : Table" and open it.
Look for the column "title" (14th column) and select the entire column by selecting the title.
Pressing <Ctrl> and <H> will pull up a find and replace window:
**Look in: Title (Should be the name of the column you highlighted)
**Match: Any Part of Field
**Search: All

Now what I did was search for : and replaced it with -
Then I searched for & and replaced it with the word - and.

Close "Access" (database is automatically saved).
Reopen AllMyBooks and try to export your database to ODT again.
It works flawlessly - now.

Note: The two characters that I searched for and replaced worked for me, however; you may need to search for other special characters to resolve your issue. I recommend doing a few at a time so as not to confuse the situation.

Reply to Viki

Posted: Thu Mar 19, 2020 12:53 pm
by skc

I know OO Write will export/import to MS Word fine but I don't have MS Word. Open Office does all I need that MS Office can do. (Am now wondering however if this is the issue. i.e. to open the OO 'Write' I need MS program installed. For years AMB just exported to MS Word only and maybe this is a remnant of that?)

When I try to open the .odt I get the message:
Read-Error Format error discovered in the file in sub document contnet.xml at 1.14647 (row,col)

I tried as you recommended...
"Close AllMyBooks
Find your db on your computer, right-click, and "Open With.." and choose "Access.exe"
On the left side (under "All Tables"), choose "books : Table" and open it......"
but since I don't have MS Office I instead used the OO version, SBase. All that happened was a blank screen with the PC doing a lot of fan noise but nothing else.

It's not critical to get it sorted, (I can still export in other ways), but it would be nice considering I spent even more $$$ on the program for what overall seems a minor upgrade. (Thanks to the 'virus crisis' our exchange rate is currently 17:1 which is awful!)

Thanks for getting back to me and your efforts. A great program (also have AMM) but it would be nice if Bolide were a bit more active on their feedback. (Hopefully they're working on an update that will sort this out?) Best Wishes - Shawn

Posted: Thu Mar 19, 2020 5:16 pm
by Viki
@Shawn -

Just another thought...
Try opening AllMyBooks, under the "Database" tab select "Compress", and wait for the program to compress your database.
(The developers have stated in this forum that compressing the db will also "Fix" many irregularities in it.)

Do you store all the images inside the db? (Tools > Preferences > Expert Options). If you do, then uncheck this option under "Expert Options" and wait for AMB to move the images from your db to a folder.
Compress the db again, and then try to export to ODT...

Let us know how you progress. :)

AMB Version 5 NOT Exporting to ODT

Posted: Wed Mar 25, 2020 6:31 am
by skc
Tried all you said Viki but no joy.
Anyway now finally some feedback from Max. Lets see what happens. Not critical or urgent but would be nice if eventually it can be fixed in another update.
Thanks again for your expert and considerate help.
(BTW: This forum does not notify me by email of a reply, even though I ticked it to do that.)